History

Completed
February 8 11:35 PM IST

The maintenance completed succesfully.

In Progress
February 8 9:17 PM IST

Scheduled maintenance is currently in progress. We will provide updates as necessary.

Scheduled
February 6 10:22 PM IST

The Tide app will be unavailable from 21:00 PM to 23:30 PM on Thursday, the 8th of February.
During this time the team will be performing some routine maintenance that requires us to suspend access to the Tide app.
Tide regret any inconvenience this may cause and thank you for your understanding.