‘Add Funds’ is temporarily unavailable

Incident Report for Tide IN

Resolved

The issue has been resolved.

Thank you for your patience. We apologise for any inconvenience this may have caused.
Posted Jul 07, 2025 - 14:45 IST

Investigating

You can’t deposit money into your account through this option right now.

We’re fixing this as soon as possible – please check back here for updates. We’ll let you know as soon as you can use ‘Add Funds’ again.

Other deposits and payments are unaffected.

Thanks for your patience and we're sorry for any inconvenience.

For urgent queries, tap 'Support' in the app.
Posted Jul 07, 2025 - 13:27 IST