Issues with Account Recovery

Incident Report for Tide IN

Resolved

The issue has been resolved.

We again apologise for any inconvenience this may be causing.
Posted Nov 06, 2025 - 17:18 IST

Investigating

Due to technical issues the Account Recovery process if currently unavailable.

We are currently working to restore the service to you as soon as possible.

We apologise for any inconvenience this may be causing.
Posted Nov 06, 2025 - 00:08 IST