Incident: Several services are currently unavailable.

Incident Report for Tide IN

Resolved

All services are restored.
Posted May 21, 2025 - 21:07 IST

Identified

You may not be able to perform certain actions relating to your Tide card in the app.

Making payments and managing Payees may also be unavailable temporarily.

New customers: signing up to Tide may not be possible during this time.

We apologise for any inconvenience this may be causing.
Posted May 21, 2025 - 20:27 IST