Payments failing

Incident Report for Tide IN

Resolved

Payments are back to normal

We've resolved the issue that affected our payment services earlier.

Thanks for giving us the time to fix this.

If you still need assistance, tap 'Support' in the app - we'll be there.
Posted Mar 10, 2026 - 14:02 IST

Investigating

We’re experiencing issues with some of our app payment services including Top-ups and Bank transfers are failing.

Please don't reattempt transfers or transactions. Payments may be queued and arrive after normal service resumes.. Please check back here to see when this issue has been resolved. 

For urgent queries, tap ‘Support’ in the app.

We apologise for any inconvenience.
Posted Mar 10, 2026 - 12:51 IST