Maintenance Alert

Incident Report for Tide IN

Resolved

The issue has been resolved and you should be able to recover your account now.
Posted Sep 16, 2025 - 18:46 IST

Identified

Account recovery services are temporarily unavailable.

Thanks for your patience and we're sorry for any inconvenience.

For urgent queries, tap 'Support' in the app.
Posted Sep 16, 2025 - 16:51 IST