Tide platform outage

Incident Report for Tide IN

Resolved

The platform outage is now resolved and we are fully operational. Thank you for your patience.
Posted May 15, 2025 - 14:49 IST

Investigating

You may not be able to login or you might experience issues with other services, including payments.

We’re working quickly to restore our services as soon as possible – we apologise for any inconvenience meanwhile.
Posted May 15, 2025 - 14:13 IST