The issue affecting Utility Bill Payments, NCMC, and FASTag recharges has now been resolved fully now.
All affected services have been restored and are processing successfully.
We apologise for the inconvenience caused and thank you for your patience while we worked to resolve the issue.
Posted Jul 10, 2026 - 17:30 IST
Update
Utility Bill Payments & Recharges
Utility Bill Payments have now been restored and are processing successfully.
NCMC and FASTag recharges remain temporarily unavailable while we continue working to resolve the remaining issue.
We'll provide another update as soon as these services have been restored.
We apologise for the inconvenience and appreciate your patience.
Posted Jul 02, 2026 - 11:46 IST
Monitoring
Failing Utility Bill Payments & Recharges
To minimise disruption, we've temporarily removed Utility Bill Payments and NCMC/FASTag recharges from the Tide app while we work with our payment partner to resolve the issue.
These services are currently unavailable. We'll restore them as soon as it's safe to do so.
Please check back here for further updates. For urgent queries, tap Support in the app.
We apologise for the inconvenience and appreciate your patience.
Posted Jul 01, 2026 - 21:03 IST
Identified
Identified - Failing Utility Bill Payments & Recharges
We're currently experiencing an issue affecting some payments through payment gateway.
Some members may be unable to:
Pay utility bills (Electricity, Mobile, and others) Recharge NCMC or FASTag
We're working with our payment partner to resolve this as quickly as possible. Please check back here for updates.