Issue with payments in iOS

Incident Report for Tide IN

Investigating

We regret to inform you that adding money to your Tide Wallet, making bill payments, and completing GST/Udyam registration payments are currently unavailable.

We apologize for the inconvenience and are working to resolve this issue as soon as possible

For urgent assistance, tap ‘Support’ in the app.
Posted Apr 28, 2026 - 18:25 IST